Software for Architecture,
Engineering and Construction

Revit
CYPE
INTEROPERABILITY GUIDE
Using BIMserver.center
V 1.1.

Index
1

Introduction ............................................................................................. 3

2

IFC concepts ............................................................................................. 4
2.1 Terminology and IFC structure............................................................... 4
2.2 Characteristics of a Revit IFC .................................................................. 5

3

Workflow Revit - CYPE ............................................................................ 6
3.1 General settings .......................................................................................6
3.2 Open BIM plugin for Revit ...................................................................... 7
3.3 Analysis of possible exportation errors ................................................ 8

4

General settings ...................................................................................... 9
4.1 Mapping settings .....................................................................................9
4.2 Levels.......................................................................................................11
4.3 Rooms .....................................................................................................12
4.4 Walls ........................................................................................................15
4.5 Floors.......................................................................................................17
4.6 Roofs .......................................................................................................18
4.7 Links ........................................................................................................19
4.8 Central and local models ......................................................................20
4.9 Origin, base and survey points ............................................................21
4.10 Phases .....................................................................................................22

5

Structures............................................................................................... 23
5.1 Calculation of structures with CYPECAD .............................................23

6

Installations ........................................................................................... 24
6.1 Calculation of general installations .....................................................24
6.2 Calculation of advanced installations ..................................................25

7

Energy calculation ................................................................................ 26
7.1 Spaces .....................................................................................................26
7.2 Curtain walls ...........................................................................................27
7.3 North of the project ...............................................................................28
7.4 Energy settings .......................................................................................29
7.5 Foundation slabs and base slabs:
export of specific classes and types ....................................................30

8

Exporting from CYPE to Revit .............................................................. 33
8.1 Tags .........................................................................................................33
8.2 Schedules ................................................................................................33

9

Augmented reality ................................................................................ 34

1

Introduction
This guide establishes guidelines for the optimum communication between the
architectural modelling application REVIT, and CYPE’s specialist technical programs.
This communication is based on the IFC format (acronym for INDUSTRY FOUNDATION
CLASSES). IFC is an open data exchange format in the architecture, engineering and
construction sector. It is free to access (as it does not depend upon any particular
developer), and it allows for the exchange of model information between applications from
different developers.
It is not possible to develop efficient BIM models without taking into account the intended
BIM USES from the start. In this case, by not including the requirements of the IFC format
and of the CYPE tools as another BIM Use upon starting a new project with REVIT, it will
lead to the appearance of interoperability problems that can end up halting the workflow.
This is because there are two types of possible interaction with an IFC– viewing the
information that it contains (e.g. with an IFC viewer) and working with this information
(e.g. with CYPE’s calculation solutions). Whilst the first case is relatively easy to achieve, the
second interaction is very sensitive due to differences in the internal information structures
of each software program.
The IFC format is capable of transferring data from one application to another, but this
does not mean that this data follows the fundamental internal norms of the software
which it is transferred to. For example, general purpose software like Revit or Archicad,
allow the user to model elements in various ways. Such flexibility is possible because they
do not have to respond to complex specific calculations for detailed code justifications. On
the other hand, in CYPE’s solutions there is usually only one way of modelling elements –
the one which offers greater guarantees in the calculation processes of that tool. It is
important to take these restrictions into account when choosing the way in which to model
in the general purpose software if there is to be good communication.
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2

IFC concepts

2.1

Terminology and IFC structure
At CYPE we work so that the technician does not need to know in detail the internal
structure of the IFC, automatically facilitating its “correct” generation from the modelling
tools available in each program. Nevertheless, for a greater understanding of this guide
some basic concepts surrounding this term will be clarified.
IFC is a format developed by the buildingSMART initiative, for projects where there is
collaboration between users of BIM applications made by different providers. This implies
working in an Open BIM workflow as it does not depend on formats belonging to specific
developers. The most up-to-date version is IFC 4 (major release), which complies with ISO
16739:2013. Just like with all ´BIM´ formats, the IFC format contains geometric entities
with associated information in the form of parameters. These entities are grouped into
CLASSES and TYPES. CLASSES are a general grouping of elements according to what they
are (walls, floors, roofs etc.), associating attributes and dependencies to them. TYPES are a
more specific grouping within classes, that distinguish between their individual specific
components (for example, the CLASS IfcBeam, that describes any type of beam, hosts
various specific TYPES of beam, such as BEAM, JOIST, HOLLOWCORE, LINTEL, SPANDREL,
etc).
The standardised system of CLASSES and TYPES is fundamental during the import of an IFC
as they are the programs’ way of finding the entities that they need. For example, a
structures application will search for a series of classes and types (e.g. IfcColumn) in order
to import, interpret and work from. Each CLASS is also assigned a default and standardised
set of basic parameters known as P-SET. For instance, the CLASS IfcWall is assigned a P-SET
that contains parameters such as U-value, Load-bearing, Sound insulation class, Fire
behaviour, etc. This is a set of data relevant to that CLASS that will be displayed in viewers
and worked with in programs that import IFC.
Each IFC file is assigned a MODEL VIEW DEFINITION (MVD); this is its function (what that
IFC will be used for), so that its data is organised and optimised for that purpose. A
structural MVD will mean that the IFC only contains information relevant to the analysis
and calculation of the project’s structure.
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2.2

Characteristics of a Revit IFC
In an IFC there are 3 types of element that Revit is capable of exporting according to the
geometric operation with which they are generated:
1.

Extrusions: of a straight extrusion profile.

2.

Sweeps: through a direction vector.

3.

B-rep: Boundary Representation. They can either be vertices with coordinates in space
that join with the edges and form the object, or NURBS surfaces.

The three previous entities are correctly represented in the three-dimensional space of the
IFC and can also be used for model coordination jobs. Each element, independent of the
way the geometry has been generated, will have its own corresponding IFC class and type.
For example, there can be a wall element of the class “IfcWall” that is a simple extrusion,
but also an “IfcWall” that is a B-rep. In both cases the “IfcWall” could have exactly the same
properties.
However, it should be remembered that each software program has its own rules
regarding the generation of geometry. In general, the simpler the geometrical definition of
an element, the more possibilities there are that another application is able to recognise
the entity and continue working with it. The easiest are simple extrusions, whereas B-Rep
are the most complex entities.
Due to the structure of Revit’s IFC exporter, when you export to IFC it will attempt to
generate almost all of the entities as a simple extrusion profile. Only in cases where it is
impossible to geometrically define them as an extrusion, the surface will be exported as a
sweep, and in final instance, as a B-rep.
All of this is especially relevant to the way in which you model within Revit. Achieving a
model which is capable of exporting itself entirely as a simple extrusion will greatly
contribute to good communication with other tools, including CYPE’s suite of programs.

CYPE-Revit Interoperability Guide / 5

3

Workflow Revit - CYPE

3.1

General settings
The IFC format allows information to be exported from a specific application to other
applications of other developers, in order to view and work with the information. The most
important thing in the REVIT-IFC-CYPE workflow is the optimisation of the information that
is exported to subsequent applications. This means that:
1.

It is safest to export simple models, when you have the basic architectural elements
relevant to development in specific applications (walls, partitions, slabs, doors,
windows, etc). This does not mean that a detailed Revit model cannot be exported –
section 4.1. Mapping settings details how to specify which entities to export to IFC.
Nevertheless, exporting a simple model is the best way to guarantee a fluid
interoperability.

2.

Model as much as possible according to the guidelines laid out in this guide. Each
software program has an internal structure and logic designed for its correct
operation, with different accuracy levels according to its function. Revit is a general
purpose program, where there are various ways of doing things. However, it will be
necessary to choose the work method where the structure of the entities is similar to
the structure of the specialised applications. These applications require greater
accuracy when carrying out calculations and code justifications of structures, energy
analysis, acoustic analysis, installations etc.

Finally, it must be kept in mind that CYPE has two types of program – those that allow the
modelling of architectural elements (CYPECAD MEP, IFC BUILDER), and those that do not
(CYPETHERM, CYPEPLUMBING, CYPELUX...). Exporting to the second type is a lot easier than
to the first. If you want to transfer your Revit model to a non-modelling application, it can
be successfully exported even without following all the guidelines in this guide. As a
general rule, the more complex the exported IFC is, and the more functionalities that the
CYPE application has where you want to export to, the more accurate the model has to be
to achieve the best interoperability.
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3.2

Open BIM plugin for Revit
The best way to export to IFC to guarantee an optimal communication between CYPE
applications is to use the free export PLUGIN, available on the BIMserver.center STORE.
This PLUGIN facilitates the configuration of the IFC exporter integrated in Revit, allowing a
direct link with our project in BIMserver.center. The default configuration of this plugin will
function in the majority of cases, as long as the suggestions in this guide have been
followed. You must keep in mind that the possible limitations in the exportation process
are inherited from Revit’s IFC exporter, developed by Autodesk.

By clicking on COLLABORATE ON OPEN BIM PROJECT we have two options:
1.

Select an existing project- if there is a project in BIMserver.center where we want to
take the exported IFC we can select it by clicking on this option. It will open a pop-up
menu with a list of our projects.

2.

Create a project on BIMserver.center. We will be able to create a new project on the
platform directly from Revit in a matter of seconds.

In both cases, an IFC will be exported that is uploaded to the cloud, and will allow for
collaborative working and synchronisation with other IFCs uploaded to the same project –
both those developed in CYPE programs and those created by another tool which are
connected to the project.
When opening any CYPE application you can link directly to the project and its files and
continue working as usual with the information you have generated in Revit. Furthermore,
when the Revit file is synchronised with BIMserver.center, you will be able to link the IFCs
that already exist in this project, or those that will be added later, having access to all the
information that they contain (for example, the element and material specifications
resulting from the calculations of the structure and installations).
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3.3

Analysis of possible exportation errors
On occasions it is possible that the import to CYPE programs is not as expected, and it is
unclear why. When exporting the IFC with the PLUGIN and uploading it to
BIMserver.center, you are generating a local IFC file that serves as a conduit between Revit
and the cloud. You will find this file by default in C:\ bim_projects\ user_XXXXX\
proy_XXXXX (although this directory can be edited from the BIMserver.center
synchroniser). There will be a folder structure that serves for organising the different files
and establishing a good connection with Revit.
From here, you can open the IFC file with any free IFC viewer (e.g. BIMvision free viewer,
available on BIMserver.center) and check that all the geometry necessary to carry out the
analysis in CYPE software has been exported – if it has been exported in its correct
position, if it has the correct properties etc. For example, it is essential that IfcSpaces have
the 2nd Level Space Boundaries defined in order to carry out the energy analysis with this
IFC model.

Additionally, and as a general rule, the most difficult export is to modelling programs
such as CYPECAD MEP or IFCBUILDER: however, in this case it will be possible to
solve this problem within these same programs, remodelling the parts that haven’t
been correctly exported.

The goal is not to achieve an identical copy of Revit’s geometry in CYPE programs, but
rather to obtain a model with the necessary and sufficient information to carry out the
relevant analyses and calculations.
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4

General settings

4.1

Mapping settings
The MAPPING TABLE for IFC export is a table that determines the translation from REVIT native
entities to IFC entities. This table can be found in Revit > Export > Options > IFC Options.
For a correct export, you will have to ensure that the necessary entities for the
desired calculation model and the correct equivalence between entities are
exported.
The following table defines which REVIT entities need to be exported to which IFC entities,
depending on the applications to which the model is to be exported.
The goal is NOT to reproduce the entire Revit building in IFC, but rather to extract from
the model the necessary information to carry out certain actions with specific tools.

The graph above shows the amount of information that travels in the IFC (vertical axis), and
how much of this information needs to be interpreted as native by the different disciplines
of the project (horizontal axis).
Traditional BIM tools (Revit) are not capable of exporting the space boundaries (IfcSpace)
needed, for instance, for accurate thermal analysis as well as the information needed to
interpret thermal/acoustic bridges. However every day IFC analysis tools are improving and
at CYPE we are working on a tool capable of interpreting this missing information to
incorporate it automatically into the project. Alternatively, you can use the free BIM tool
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IFC BUILDER or CYPECAD MEP, that guarantee a model which exports the maximum
information recognisable by the CYPE suite for this type of calculations.
Alternatively, you can use the free BIM tool, IFC BUILDER or CYPECAD MEP, that guarantee
a model that exports the maximum amount of information recognised by the CYPE suite
for these types of calculations.
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4.2

Levels
In Revit, it is common to work with several levels on the same floor – at least an
architectural/ finished floor level, and one structural level. However, most of the analysis
and calculation programs in the CYPE suite are designed to work with only one level per
floor – that of its specific function.
To avoid an excess of floors in CYPE programs, it is sufficient to uncheck the “building
storey” instance parameter for those levels that are not relevant for the analysis to
be carried out. That way, those floors will not be exported and you will be able to continue
working only with the necessary levels with the specific tool.

Be careful when exporting to modelling programs such as CYPECAD MEP or IFC
BUILDER – the levels that are not exported cannot be used as a reference for the
upper or lower boundaries of the walls.

Another alternative solution would be to leave these levels unchecked when importing the
model to calculation programs.
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4.3

Rooms
The rooms are one of the most important entities, since they are the basis for many of the
calculations and analyses that can be performed on a BIM model. It will be essential to
define them correctly in order to ensure their export and accurate calculation, by applying
the following measures:

1.

Deleting unplaced rooms and spaces.

When you delete a room from any view in Revit, it is deleted from the 3D space but it
remains present in the project. To completely delete a room in a Revit project it needs to
be done from the schedule. In order to do this, go to View > Create > Schedule, and create
a schedule/quantities table where you will include at least the area. The rooms that are not
placed on the floor will have the value “not placed”. From here they can be deleted,
removing them completely from the project.
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2.

Adjustment of the upper room boundary to the lower edge of the upper slab.

Currently, Revit’s IFC 4 exporter has limitations when exporting rooms bounded by floors
and ceilings. As opposed to IFC 2x3, it is not able to correctly “trim” the shape of the room
with its horizontal bounding elements. This means that after exporting, the IfcSpace will
ignore its clash with the slabs. Therefore, to ensure that the volume of the room is correct
when exported to IfcSpace, a higher negative offset equal to the thickness of the slab must
be entered. This consideration is only necessary for the development of thermal and
acoustic studies.
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3.

Check that the volume of the rooms is being calculated.

To guarantee that the areas and volumes correctly export to IFC, it is advisable to go to
Architecture > Room and area, click and open the dropdown menu > Area and volume
computations. Once you have accessed the menu for calculations of area and volume, the
“areas and volumes” and “at wall finish” options should be checked.
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4.4

Walls
It is advisable to observe the following guidelines to ensure that the walls are correctly
exported from Revit to IFC, and that the entities are legible by CYPE software.
1.

The use of upper and lower constraints for slabs and roofs, avoiding the modification
of the wall profile sketch.

2.

It is recommended that the walls go from level to level and that there is a wall per
floor. This is especially important when exporting to modelling programs like CYPECAD
MEP o IFC BUILDER. Otherwise the import results in these programs may be
unpredictable.

3.

The use of the WALL OPENING BY FACE tool instead of drawing openings in the sketch
of the wall.

4.

It is imperative that the walls are a single integral element in layers- as is
outlined in Autodesk’s official documentation. It is not recommended to work with
exported models where each wall layer has been modelled as a separate and
independent wall type/instance.

5.

It is preferable to create linear walls instead of wall by face. If the export is made
to non-modelling programs (like CYPECAD MEP or IFC BUILDER), it will also be possible
to export more complex walls, with the limitations inherited from Revit's IFC exporter
developed by Autodesk.
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6.

The correct definition of the FUNCTION type parameter (exterior/interior) of all
the walls according to whether they are enclosure or partition walls (for thermal or
acoustic analysis programs).
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4.5

Floors
The floors are usually defined by perimeter. As with walls and roofs, it is best to model
trying to obtain shapes that can be generated in IFC by simple extrusion. To this end, it is
recommended that:
1.

Use the floor by definition of boundary lines instead of “floor by face”, although
the last option will also be possible in non-modelling programs.

2.

Sloped floors that exceed levels should be avoided. In this case it would be
advisable to make an independent sloped floor in each level, with the meeting points
of the floors being at the upper and lower edges of the respective levels. This is
especially relevant when exporting to modelling programs such as CYPECAD MEP or
IFC BUILDER.

3.

It is recommended to avoid the use of modifications of sub elements to create
slopes, since this could compromise the geometric condition of the parallelepiped
floor. Instead, for sloped floors, the definition of the family’s inherent slope arrow is
recommended.
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4.6

Roofs
For the same reasons stated in previous sections, it is important to model in such a way
that the IFC file can read the entities as simple extrusion profiles.
To this end and to optimise the best communication between programs, it is
recommended to employ, as much as possible, the following modelling practices:

In general:
1.

Create the roofs from the “Roofs” group and not from the “Floors” group. This will
allow thermal/acoustic analysis programs to be able to distinguish between both
elements and correctly perform the calculations.

2.

It is recommended to create roofs by footprint and not by extrusion.

3.

Associate the roofs to levels to be exported, avoiding gaps as much as possible.

4.

Those sub-elements defined to divide hips or to simulate the evacuation slopes
into flat roofs will not be considered. This slope entered in Revit won’t be useful data
for further calculations and analysis.
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4.7

Links
One of the limitations of Revit’s IFC exporter is the export of links to IFC.
The exporter has many problems with the geolocation of links (correct export when
coordinates are referenced to the Reference Point), and their correct relative positioning if
they are moved or rotated. As for links where symmetry has been applied, the export does
not work.
Therefore, the best way to guarantee a correct and stable export if the project shares
Reference Point Coordinates will be to bind all the links that you want to bring to IFC and
export the unified project. This can be done in a separately saved temporary file whose
purpose is the correct export to IFC. To attach, select the link and click on Modify > Link >
Bind.
The binding of all the links can be difficult at times, since big projects can contain a great
number of objects and geometry, and Revit is not capable of supporting many elements
simultaneously due to excessive RAM usage. In these cases you must be bear in mind that
the important thing is not to transfer the whole model to IFC, but only the elements
relevant to what you want to do. It is therefore recommended to delete all categories that
do not serve this purpose, optimising the file’s entities and being able to finally carry out
the attachment of all the links.

Even though the Open BIM plugin for Revit will try to unify all the links into one IFC
file, binding everything will be the safest option if we face any issue regarding the
model federation.
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4.8

Central and local models
In the case of models where collaboration between users is taking place, it is possible to
export to IFC from any of the project’s local files. However, issues can arise with Revit’s IFC
exporter due to the ownership of permissions of the user who exports the worksets. To
avoid these possible issues and errors, a good practice is to create a temporary copy of the
local file that is detached from the central file. This can be done by opening the file from
Revit’s file opening manager, where the box “detach from central” must be checked. Ideally,
the worksets will also be discarded.
This temporary file will be needed only when exporting, and it only needs to be created
once. Once the IFC file has been exported with the necessary entities and the correct
import has been checked in the corresponding specific CYPE applications, the temporary
detached .rvt file can be deleted. It is important to carry out the export with the free CYPE
for Revit PLUGIN and following all the guidelines in this guide to guarantee an optimal
interoperability.
To integrate the information generated in CYPE tools into the workflow of teams
collaboratively working in Revit, simply create new IFC files from those specific applications
containing the necessary technical information and code justification, which can then be
linked back into Revit from any of the local files using the “Link IFC” tool within the
corresponding worksets. Changes made in the CYPE applications will be synchronised
when the linked IFC files are overwritten, and their updated information is transferred to
the central model.
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4.9

Origin, base and survey points
In Revit there are three origin or reference points: the origin point (invisible and linked to
the survey point, the real centre of the file), the base point (circular, local project centre)
and the survey point (with a triangle symbol, global centre of the project)
This is especially important when working on projects that contain linked files, as it is very
easy for such files to be moved from their federated position in the export process. This is
one of the biggest limitations of Revit’s IFC exporter.

In general, it is best to export using the survey point in order not to lose the
georeferencing of the model. However, due to the limitations of Revit’s native
exporter, this guide recommends using the survey point if linked files exist.

The other solution is to connect all the links when exporting (in a temporary file whose sole
purpose will be the generation of the IFC) and also export from the survey point. Otherwise
the federation of the linked models will be compromised, and it is very likely that they will
move from their correct position in the export process.
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4.10

Phases
One of the limitations of Revit’s IFC exporter is that it only allows one phase to be exported
at a time. In any case, the phases won’t be relevant for CYPE’s calculation and analysis
programs. As such, the best and most stable way to export to IFC will be to delete the
phases that have elements that we don’t need, and to connect the phases that do, leaving
the project with just one phase. This can be done in MANAGE> PHASES.
When we connect phases it’s important to check that no element information is lost –in
particular, the rooms – and that in the Energy Settings and Revit’s IFC Exporter, the
phase that we are left with is selected.
This would only need to be done when exporting to IFC. In order not to lose project
information, this can be done by previously saving the file in a temporary parallel copy that
will only be used for export. At the end of the process we will be able to bring to Revit the
different calculation IFCs generated with CYPE programs, and assign the linked IFCs to their
respective phases.
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5

Structures

5.1

Calculation of structures with CYPECAD
Revit’s communication with CYPECAD will allow us to take advantage of some of the
information developed in Revit for the analytical definition, structural calculation and
automatic generation of the justification report. Furthermore, it will be possible to
consolidate the information in BIMserver.center or in Revit via IFC.
For good communication between Revit and CYPECAD it will be necessary to:
1.

The columns will be exported as IfcColumn, which CYPECAD is able to import as native
columns.

2.

Model the slabs as Floors, which will be imported as boundaries that can be converted
into native CYPECAD slabs at the click of a button.

In CYPECAD the structural elements can be defined in detail (beams, columns, slabs) with
their respective characteristics, as well as the stresses exerted on the structure.
For an optimal communication between Revit and CYPECAD, this should be done through
the free Open BIM plugin for Revit.
Once the calculation has been completed the file can be exported from CYPECAD to IFC,
which will contain the geometry, analysis data and justification report. Moreover, you will
be able to obtain automated rebar plans for all the concrete elements in DWG format.
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6

Installations

6.1

Calculation of general installations
To calculate small or medium sized installations and automatically justify specific code
checks it’s common to work with the CYPECAD MEP tool. From this program you will be
able to resolve all of the code check sections related to energy efficiency, noise protection,
fire, plumbing, sanitation, HVAC, solar thermal, lighting, electricity, telecommunications and
lightning conductors.
By exporting to IFC with the free Open BIM plugin for Revit and then importing the IFC by
searching in the local folder C: > bim_projects > project folder > IFC, you can quickly
redefine all the construction elements of the project and automatically generate all the
required calculations and justification reports.
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6.2

Calculation of advanced installations
The new applications that CYPE is developing, integrated into the Open BIM workflow,
extend the possibilities of CYPECAD MEP whose approach is more general. They offer the
designer and engineer design tools that reach higher levels of detail and definition in
installations of energy efficiency, fire protection, plumbing, sanitation, electricity, HVAC,
noise protection, etc.
Many of these applications have been custom-designed with particular products from
specific manufacturers, and allow users to calculate specific systems with automatic
justification of the corresponding application codes. Furthermore, the decentralisation of
disciplines into more sophisticated applications makes it possible for several users to work
collaboratively on the same project –with cloud synchronised tools for tracking changes,
discipline coordination, clash detection and multiplatform augmented reality.
The communication with these applications is similar to the case of structures – using the
free Open BIM plugin for Revit. Simply export the architectural elements and the spaces
with their respective IFC Classes in order to be able to calculate the corresponding
installation.
Once the calculations have been carried out, they will be updated in BIMserver.center,
where you can continue developing the project alone or collaborate with other users, or
consolidate the information back into Revit.

CYPE-Revit Interoperability Guide / 25

7

Energy calculation

7.1

Spaces
Revit spaces are also exportable entities to IfcSpace, so you can work with both rooms and
spaces in Revit and achieve their export to IFC in the same way. In any case, if both entities
exist in the project it must be ensured that there is no overlap in the exported IFC; that is to
say, the mapping sheet must be configured so that the spaces are not exported. To do this,
go to File > Export > Options > IFC Options, and write “not exported” in the boxes
referring to the spaces.
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7.2

Curtain walls
For curtain walls, everything described for normal wall families will apply. Additionally, for
correct reading and analysis in CYPE software, the following needs to be taken into
account:

In general:
In the case that you want to export to analysis and calculation tools only (e.g. CYPETHERM
or CYPELUX): in the export mapping table to IFC entities, the curtain walls (curtain wall
systems, curtain wall panels and curtain wall mullions) must be exported as IfcWindow and
not as IfcCurtainWall, as is the default setting.

Exportation to other modelling programs:
When exporting to other modelling programs such as CYPECAD or IFC BUILDER, Revit does
not allow the curtain wall generation system to be exported to IFC as an importable and
geometrically editable element. It will be necessary to convert the curtain walls to normal
walls and create window families in them that go from the floor to the roof, similar to the
curtain wall that was planned.
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7.3

North of the project
It is possible to establish the orientation of the project directly in Revit. To do this, go to any
view of the floor and under viewing properties select Orientation > True north. Next, go
to Manage > Position > Rotate true north and the geographic orientation of the project
can be defined.
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7.4

Energy settings
To export the rooms correctly check in Analyse > Energy Optimisation > Energy Settings
that the defined PROJECT PHASE is the phase that will be exported to IFC.
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7.5

Foundation slabs and base slabs: export of
specific classes and types
By default, Revit does not export foundation slabs and screed as they are defined in the IFC
standard. In order to export these elements an adjustment will need to be made so that
CYPE applications can recognise them. For this purpose it is necessary to define not just
the CLASS of the floor (IfcFloor), but also its TYPE (BASELAB).

Fortunately, in Revit the TYPES can be defined by instance. All you have to do is create a
Shared Project Parameter: go to Manage > Settings > Shared Parameters > Create,
select their location, and then create a new GROUP and a new PARAMETER with the name
“ifcExportAs”. It is important that it is called exactly that, without the speech marks and with
the upper and lower case letters, selecting TEXT as the parameter type.
Now you have to enter the shared parameter created as an instance project parameter. To
do this, go to Manage > Settings > Project Parameters > Create, and click on Shared
Parameter > OK. Select the .txt file created previously and the “ifcExportAs” parameter.
Apply it to the Floor Category, make sure that it is grouped under IFC Parameters and click
on OK.
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Now all of the floors will have the project parameter ifcExportAs. What is written in this box
will determine which CLASS and TYPE of IFC entity this specific instance will have – this has
priority over the general mapping table.
In order for it to work, “ifcClass.IfcType” needs to be written inside the box; therefore, in
this case we will write IfcSlab.BASESLAB. Now this floor will be exported as IfcFloor and
CYPE will be able to recognise it directly as a foundation slab or beam in both analysis
(CYPETHERM) and modelling programs (CYPECAD MEP).

If you do not wish to do this you will always be able to export this element as a slab,
without making any adjustments, and change its characterisation in the target program.
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Exporting from CYPE to Revit

8.1

Tags
When an IFC is linked, Revit’s native importer automatically creates a shared parameters
file (FileName.ifc.sharedparameters.txt) in the project’s directory, which contains the type
and instance parameters of the linked IFC entity. To tag a linked IFC entity (for example, a
column from a CYPECAD structure) the following steps are required:
1.

Create a new tag family (or modify an existing one).

2.

Load the shared parameters file created when the IFC was linked inside Revit’s family
editor.

3.

Enter in the tag text the parameter in question (for example, IfcName).

If you load that tag family into the project you will be able to tag all of the columns without
any problem. It will even be possible to tag multiple columns at once using the “tag all” tool
if the “include elements from linked files” box is activated.

8.2

Schedules
To create schedules with IFC links, create a new schedule in whose “properties” > “fields”>
“include elements in links” box is activated. You can tabulate all IFC parameters by loading
them in the available fields from the same shared parameters file.
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9

Augmented reality
The free BIMserver.center AR application, available for iOS and Android, allows you to view
any BIM project that has been exported to IFC in Augmented Reality at any scale, both
models exported from CYPE programs and models exported from Revit with the free Open
BIM for Revit plugin.
This greatly increases the possibilities to view and review the project- allowing the display
of 3D scaled models from all calculated disciplines of the project, and being able to select
all of its elements to access the associated information.
These models are synchronised with BIMserver.center so that they don’t take up space on
devices, allow the immediate display of all the BIM projects of the user in question and are
updated with the latest version of all the files that build the Open BIM projects.
Issues and coordination reviews will also be updated in this virtual model in real time,
connected to a mobile phone notification system.
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